Osy Rios preguntado en Computadoras e internetSoftware · hace 1 década

En Excel ¿Es posible cambiar automáticamente la referencia a una hoja en una fórmula?

Mi jefe hizo un libro en Excel con una hoja concentradora de datos y 12 hojas llamadas "Enero", "Febrero", "Marzo"...

Deseo que al poner en una celda de la hoja concentradora el nombre del mes, automáticamente se cambien las fórmulas para que me tome los datos de la hoja del mes correspondiente.

Por ejemplo: alguna fórmula dice

=Enero!SUMA(T1:T10).

Si deseo ver los datos de febrero, debo cambiar manualmente unas 20 fórmulas para que se refieran a la hoja "Febrero". Lo ideal sería que quedara algo así como

=Valor_en_D8!SUMA(T1:T10)

ya que en D8 pongo el nombre del mes al que corresponde el concentrado.

Macros, tablas, tablas dinámicas, cualquier idea, por favor, antes de hacerlo en Acces y recapturar todo de nuevo.

3 respuestas

Calificación
  • ZATIRO
    Lv 5
    hace 1 década
    Respuesta preferida

    Cordial saludo.

    Lo mejor como dice "El cacho" es utilizar la función indirecto, pero la fórmula te quedaría asi:

    =SUMA(INDIRECTO(D8&"!T1:T10"))

    Así solo tendrás que cambiar el mes en la celda D8 y listo

    Ahora si lo quieres mas funcional, en algun sector de alguna hoja que no necesites colocas los meses, por ejemplo en la primera hoja en las celdas A100:A111, (celda A100 enero, A101 febrero.....etc).

    Luego a este rengo le das un nombre por ej "mes" asi:

    Seleccionas el rango A100:A111 y luego das Insertar - Nombre - Definir, en el cuadro que aparece colocas mes y das aceptar.

    Luego vas a la celda D8 de la hoja concentradora que tu llamas o sea donde vas a colocar el mes.

    Alli das Datos - Validación y en la pestaña Configuración donde dice Permitir colocas Lista y donde dice Origen colocas =mes, das aceptar y listo. Te queda un listado desplegable de los meses y con solo escoger el mes este te aparecerá en la celda y si tienes ya las fórmulas modificadas con la función indirecto como te señalé arriba, automaticamente te aparecerá la informacion del mes correspondiente.

    Si tienes compliques, me mandas el archivo y yo te lo modifico con gusto.

    Exitos

    Diego

    diegoman_98@yahoo.com

    • Commenter avatarInicia sesión para responder preguntas
  • hace 1 década

    Hay varias formas de hacerlo. Pero te sugiero las más sencillas:

    1º MÉTODO:

    Seleccionada tu hoja "Resumen" vas a "Reemplazar" (Edición ---> Reemplazar) y pones:

    Buscar: Enero!

    Reemplazar con: Febrero!

    Y con "Reemplazar todas" solucionas tu problema.

    2º MÉTODO:

    En cada fórmula reemplazas el rango: Enero!T1:T10 por:

    INDIRECTO(D8 & "!T1:T10")

    Aquí simplemente vas modificando el valor de la celda "D8" poniendo el mes a resumir.

    Saludos

    ...

    • Commenter avatarInicia sesión para responder preguntas
  • hace 1 década

    se puede hacer en office 2003 o 2007

    • Commenter avatarInicia sesión para responder preguntas
¿Aún tienes preguntas? Pregunta ahora para obtener respuestas.